[fpc-pascal] Cannot find system type "__m64"

Ryan Joseph genericptr at gmail.com
Fri Mar 6 03:15:00 CET 2020

I'm continuing this from the bug tracker. Also please note that for some reason the mail list server has stopped sending me replies to gmail so I need to look at https://lists.freepascal.org/pipermail/fpc-pascal/ for replies until this get fixed. Maybe time to get rid of gmail? My private web host email was also failing though. :P


~/Developer/ObjectivePascal/fpc-git/compiler/x86_64/pp test.pp

error: Cannot find system type "__m64". Check if you use the correct run time library.


Can anyone explain this error? I have a trunk repository which I update from svn and a dev repository that I update from git (and build using the supplied lazbuild projects). After I updated the trunk compiler I started getting this error when building the dev compiler. Sven says "you need to cleanly rebuild your trunk system with a release compiler." I tried:

make clean all FPC=/usr/local/lib/fpc/3.0.4/ppcx64 OPT='-XR/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX.sdk'

but this doesn't seem to help. Tried deleting the lazbuild units and trying again also but that doesn't work. Are the wrong RTL files be used or something?

	Ryan Joseph

More information about the fpc-pascal mailing list