[fpc-pascal]Linux RedHat v.8.0, fpc and mysqlclient: /usr/bin/ld: cannot find -lmysqlclient

Marco van de Voort marcov at stack.nl
Tue Jul 1 00:33:02 CEST 2003

[top-quote somewhat fixed]

> > If the above thing still fails, simply add
> >
> > -Fl/usr/lib/mysql
> >
> > to your fpc.cfg as an override to the normal ld configuration.

> Thanks for youy reply... but partially solved the problem...
> I used "ldconfig", the machine took a little while... then.. I modified
> the "fp.cfg" (adding a "-Fl/usr/lib/mysql/" line, it wasn't there)... then
> y tried to compile "testdb.pp" again:
> 1) From the "FreePascal IDE" It worked fine, It compilled... SOLVED.
> 2) BUT using "fpc testdb.pp" gets the same error "/usr/bin/ld: cannot find
> -lmysqlclient": I veryfied thad I have two "fp.cfg" files, one in
> /root/fp.cfg" and other in "/usr/bin/fp.cfg", but now, both are the same.
> And still do not compile with "fpc testdb.pp".
> Any other extra idea ?

That's because I said "fpc.cfg", usually in /etc originally (the
commandline compilers file), not "fp.cfg"

The equivalent with the IDE is not hand-editing fp.cfg, but adding the directory
to "linker directories" or something like that in options->directories.

More information about the fpc-pascal mailing list