[fpc-pascal]Linux RedHat v.8.0, fpc and mysqlclient: /usr/bin/ld: cannot find -lmysqlclient

arturogr at gorsa.net.mx arturogr at gorsa.net.mx
Tue Jul 1 00:51:50 CEST 2003

Thanks for youy reply... but partially solved the problem...

I used "ldconfig", the machine took a little while... then.. I modified
the "fp.cfg" (adding a "-Fl/usr/lib/mysql/" line, it wasn't there)... then
y tried to compile "testdb.pp" again:
1) From the "FreePascal IDE" It worked fine, It compilled... SOLVED.

2) BUT using "fpc testdb.pp" gets the same error "/usr/bin/ld: cannot find
-lmysqlclient": I veryfied thad I have two "fp.cfg" files, one in
/root/fp.cfg" and other in "/usr/bin/fp.cfg", but now, both are the same.
And still do not compile with "fpc testdb.pp".
Any other extra idea ?

>> I am trying to get access to a DataBase in a MySQL server from a Linux
>> RH 8.0 machine (I modified the testdb.pp in order to access the DB):
>> (from a MS-Win98SE machine I got my program to work using/copying the
>> libmySQL.dll into windows\system)
>> I have in the linux machine the "mysqlclient9" installed
>> (mysqlclient9-3.23.22-8)
>> In "/etc/ld.so.conf" I have "/usr/lib/mysql" line. In
>> "/usr/lib/mysql/" I have many ".so" files, "libmysqlclient.so" file is
>> there.
> Did you run ldconfig?
>> And when compilling: fpc testdb.pp
>> I get:
>> ..
>> ..
>> /usr/bin/ld: cannot find -lmysqlclient
>> testdb.pp(88,3) Error while linking)
>> Closing script ppas.sh
> If the above thing still fails, simply add
> -Fl/usr/lib/mysql
> to your fpc.cfg as an override to the normal ld configuration.

Do You GorSA ! ?
   "WebMail hecho facil y sencillo."

More information about the fpc-pascal mailing list