[fpc-devel] Windows Console App

Gerhard Scholz gs at g--s.de
Sun Apr 26 07:58:02 CEST 2020


I would like to know how you did that since it was exactly what I was 
searchomg for a while ago...

Could you send me a piece of code?



----- Original Message ----- 
From: Ozz Nixon via fpc-devel
To: FPC developers' list
Cc: Ozz Nixon
Sent: Sunday, April 26, 2020 2:21 AM
Subject: [fpc-devel] Windows Console App

Anyone ever experience making a console app (cross-platform), but, on 
windows when the app finishes, it appears to have put an uppercase C or D in 
the keyboard buffer, so the Prompt now has C:\>D<cursor>  ???

Every time I run my app, be it show help screen and end, or actually 
execute - when it finishes I end up with a letter sitting at the prompt. (A 
few months ago, I was having a problem, and it was related to compiling all 
of the methods with cdecl. That build would leave a stray "C" at the start 
of the prompt upon exiting. Now, I ran into a new problem where I needed to 
recompile with -FcUTF8 to track down which units it thought were having a 
UTF-8 mismatch... it was showing the wrong unit until I used the -FcUTF8 
compile option, then it actually showed what file had '<highbit ascii>' 
strings ... so I switched to #<byte_number> and it compiles, but, the 
prompts have "D" at the start of them now.    (hopefully I described that 

Environment: Windows XP 32bit

If no one else has experienced/has a solution, I will sit down and bang out 
test cases until I find what combination (units, code, whatever) is 
producing this result.


fpc-devel maillist  -  fpc-devel at lists.freepascal.org

More information about the fpc-devel mailing list