[fpc-devel] Windows Console App

Ozz Nixon ozznixon at gmail.com
Sun Apr 26 08:31:41 CEST 2020

Sure! I assume you are asking how to make a console app?

You do not need {$APPTYPE CONSOLE} ... instead, you simply write your code
like normal:

Program example;



then in the command prompt (any OS), simply fpc example  .... then
.\example, or ./example - depending upon your OS... voila. "Console
App".... now, that is not a DOS 16bit APP... that requires other mess, and
since I own Turbo Pascal 7.0 source, I have my own TP 32bit compiler that
produces TP 7 compatible 16bit Units and Apps. ;-)

@ you can get me at ozznixon at gmail.com if you need any help (I do not
normally code GUI apps - money in the Legacy market) so I have made a wide
range of solutions. This email was started because of something odd on
Windows recently for me...


On Sun, Apr 26, 2020 at 1:27 AM Gerhard Scholz <gs at g--s.de> wrote:

> Hi,
> I would like to know how you did that since it was exactly what I was
> searchomg for a while ago...
> Could you send me a piece of code?
> Greetings
> Gerhard
> ----- Original Message -----
> From: Ozz Nixon via fpc-devel
> To: FPC developers' list
> Cc: Ozz Nixon
> Sent: Sunday, April 26, 2020 2:21 AM
> Subject: [fpc-devel] Windows Console App
> Anyone ever experience making a console app (cross-platform), but, on
> windows when the app finishes, it appears to have put an uppercase C or D
> in
> the keyboard buffer, so the Prompt now has C:\>D<cursor>  ???
> Every time I run my app, be it show help screen and end, or actually
> execute - when it finishes I end up with a letter sitting at the prompt.
> (A
> few months ago, I was having a problem, and it was related to compiling
> all
> of the methods with cdecl. That build would leave a stray "C" at the start
> of the prompt upon exiting. Now, I ran into a new problem where I needed
> to
> recompile with -FcUTF8 to track down which units it thought were having a
> UTF-8 mismatch... it was showing the wrong unit until I used the -FcUTF8
> compile option, then it actually showed what file had '<highbit ascii>'
> strings ... so I switched to #<byte_number> and it compiles, but, the
> prompts have "D" at the start of them now.    (hopefully I described that
> understandable).
> Environment: Windows XP 32bit
> C:\FPC\3.0.4\bin\i386-Win32\fpc.exe
> If no one else has experienced/has a solution, I will sit down and bang
> out
> test cases until I find what combination (units, code, whatever) is
> producing this result.
> Ozz
> _______________________________________________
> fpc-devel maillist  -  fpc-devel at lists.freepascal.org
> https://lists.freepascal.org/cgi-bin/mailman/listinfo/fpc-devel
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20200426/03ba02d2/attachment.html>

More information about the fpc-devel mailing list