[fpc-devel] Lazarus issues on ARM Linux

mcatudal at comcast.net mcatudal at comcast.net
Mon Apr 8 19:44:01 CEST 2013

----- Original Message -----
From: "peter green" <plugwash at p10link.net> 
To: "FPC developers' list" <fpc-devel at lists.freepascal.org> 
Sent: Monday, April 8, 2013 8:49:06 AM 
Subject: Re: [fpc-devel] Lazarus issues on ARM Linux 

Michel Catudal wrote: 
> I am also having some issues with Lazarus, I am not sure if it is the 
> right forum to talk about it. I had a previous version working fine on 
> Rasphberry Pi. 
> For some reason I can't get it to work on Mele A2000G. I have compiled 
> it on gentoo on the Mele, using distcc and locally, same results. I 
> didn't get any error during compile so I was expecting it to work. fpc 
> seems to work, I haven't written any code with it yet, I was expecting 
> to use lazarus to do that. 
> My system on Mele A2000G is gentoo with mate desktop. I have 
> everything compiled with hard float as I did on the Raphsberry Pi. 
Upstream 2.6.x does not support the hard float ABI so unless you have a 
patched version (such as the one shipped in debian) it won't correctly 
link against C libraries on a system that uses hard float ABIS. Also 
even when the hard float ABI support is present in the compiler source 
code you need to either bootstrap with a starting compiler that uses the 
hard float ABI or explictly specify -d FPC_ARMHF during the build. 
fpc-devel maillist - fpc-devel at lists.freepascal.org 

This web editor from comcast doesn't work correctly, only the winblows way with messages on top, so here : 

--- start of response-- 

I am not using an upstream binary file but compiled my own on gentoo. On gentoo you compile everything. The scripts that come with gentoo ARM are setup for hard floats only. I will check what you are saying tonight anyway. I will first write some pascal code to test. I think that lazarus might be the only problem since fpc didn't barf when I ran it. 

I might have tried lazarus on debian on Rasphberry Pi, not sure, I will double check that. I know that it worked perfectly when I did and it was hard float. I will just use Rasphberry pi as a programmer for AVR32 and PIC32, too slow for anything graphical. 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20130408/9ada7a7c/attachment.html>

More information about the fpc-devel mailing list