[fpc-devel] Lazarus issues on ARM Linux

Michel Catudal mcatudal at comcast.net
Mon Apr 8 22:32:32 CEST 2013

Le 2013-04-08 13:44, mcatudal at comcast.net a écrit :
> I am not using an upstream binary file but compiled my own on gentoo. On gentoo you compile everything. The scripts that come with gentoo ARM are setup for hard floats only. I will check what you are saying tonight anyway. I will first write some pascal
> code to test. I think that lazarus might be the only problem since fpc didn't barf when I ran it.
> I might have tried lazarus on debian on Rasphberry Pi, not sure, I will double check that. I know that it worked perfectly when I did and it was hard float. I will just use Rasphberry pi as a programmer for AVR32 and PIC32, too slow for anything graphical.
> Michel

It was on debian that I tested Lazarus. On my rasphberry Pi I tried both. I went to debian when I realized that it was no possible to get firefox compiled on gentoo on the rasphberry Pi. Funny thing, I had no problem compiling it on Mele A2000G same
version 17.0.
I did manage to compile Mate Desktop on the raphberry Pi. It is not very fast though, much better on Mele A2000G.

I will try to compile the way you explained later this week and will post my results.

For Linux Software visit

More information about the fpc-devel mailing list