[fpc-devel] FPC / Lazarus potential bug Project Options Dialog

cobines cobines at gmail.com
Sun Jan 31 07:06:08 CET 2010

2010/1/31 Andrew Brunner <andrew.t.brunner at gmail.com>:
> I wanted to know if anyone has had any success with executing shell
> scripts on builds.  Lazarus has a dialog for project options and
> compiler.  In compiler section there is a GUI for "Execute before".  I
> had all three options checked (Compile, Build, Run) with the shell
> script ./prebuild.sh

It is working for me. On Windows and Linux. I have "Before: Compile,
Build" checked. Command is:
"_getsvnrev.cmd $(LazarusDir)"

The script is run from the project directory (the one with .lpi).

> This script is set as executable and the permissions were incorrect at
> first but Lazarus knew to throw me the error.  I fixed the permissions
> but get an error 127 on building the project.  I tried ./prebuild.sh
> and just prebuild.sh and the full path/prebuild.sh and all of them
> threw the same error on building.

Can you run the script directly? (./prebuild.sh)
Make sure the script returns 0 if successful.


More information about the fpc-devel mailing list