[fpc-devel] FPC / Lazarus potential bug Project Options Dialog

Andrew Brunner andrew.t.brunner at gmail.com
Sun Jan 31 21:16:10 CET 2010

Thanks, I just added the exit 0 to the script.  I can execute the
script and it does what it is supposed to do.  I just can't get the
script to run before I build via Lazarus.   No matter what I do I keep
seeing the error 127.  Any other ideas?

TExternalToolList.Run Exception: the process exited with error code 127


On Sun, Jan 31, 2010 at 12:06 AM, cobines <cobines at gmail.com> wrote:
> 2010/1/31 Andrew Brunner <andrew.t.brunner at gmail.com>:
>> I wanted to know if anyone has had any success with executing shell
>> scripts on builds.  Lazarus has a dialog for project options and
>> compiler.  In compiler section there is a GUI for "Execute before".  I
>> had all three options checked (Compile, Build, Run) with the shell
>> script ./prebuild.sh
> It is working for me. On Windows and Linux. I have "Before: Compile,
> Build" checked. Command is:
> "_getsvnrev.cmd $(LazarusDir)"
> The script is run from the project directory (the one with .lpi).
>> This script is set as executable and the permissions were incorrect at
>> first but Lazarus knew to throw me the error.  I fixed the permissions
>> but get an error 127 on building the project.  I tried ./prebuild.sh
>> and just prebuild.sh and the full path/prebuild.sh and all of them
>> threw the same error on building.
> Can you run the script directly? (./prebuild.sh)
> Make sure the script returns 0 if successful.
> --
> cobines
> _______________________________________________
> fpc-devel maillist  -  fpc-devel at lists.freepascal.org
> http://lists.freepascal.org/mailman/listinfo/fpc-devel

More information about the fpc-devel mailing list