[fpc-devel] Rebuild Lazarus fails for some reason

Michael Van Canneyt michael at freepascal.org
Thu Feb 19 09:22:36 CET 2009

On Thu, 19 Feb 2009, ABorka wrote:

> Hi Michael,
> Yes it was compiled when "make all" was called the first time, because
> c:\lazarus\ideintf\units\i386-win32\ contains componenttreeview.ppu and
> componenttreeview.o and both has the same date/time as all the other units
> there (obviously, because all of them were created with the "make all" command
> at once in step 5).
> That is why it is very strange why this is happening.
> It is a totally clean svn checkout and compilation, and without doing anything
> within Lazarus, Im just trying to do a Tools->Rebuild Lazarus from menu after
> Lazarus is first started. Of course, I got the error originally when tried to
> add a package so I tried to track back what the problem is.
> But even with a clean FPC/Lazarus SVN checkout and build this problem is
> there.
> I have no idea why it wants to recompile this unit, when nothing changed, no
> packages added or removed, its just a simple rebuild Lazarus from the Tools
> menu after a clean install.

That's why you need to turn on more verbose messaging (-u -t), normally the
compiler tells you why it wants to recompile a unit.


More information about the fpc-devel mailing list