[fpc-devel] Rebuild Lazarus fails for some reason

ABorka fpc-devel at aborka.com
Thu Feb 19 09:19:38 CET 2009

Hi Michael,

Yes it was compiled when "make all" was called the first time, because 
c:\lazarus\ideintf\units\i386-win32\ contains componenttreeview.ppu and 
componenttreeview.o and both has the same date/time as all the other 
units there (obviously, because all of them were created with the "make 
all" command at once in step 5).
That is why it is very strange why this is happening.
It is a totally clean svn checkout and compilation, and without doing 
anything within Lazarus, Im just trying to do a Tools->Rebuild Lazarus 
from menu after Lazarus is first started. Of course, I got the error 
originally when tried to add a package so I tried to track back what the 
problem is.
But even with a clean FPC/Lazarus SVN checkout and build this problem is 

I have no idea why it wants to recompile this unit, when nothing 
changed, no packages added or removed, its just a simple rebuild Lazarus 
from the Tools menu after a clean install.

Michael Van Canneyt wrote:
> On Wed, 18 Feb 2009, ABorka wrote:
>> Hi,
>> I'm getting
>> "componenttreeview.pas(41,18) Fatal: Can't find unit ComponentTreeView used by
>> ObjectInspector"
>> On this computer (win32, XP) rebuilding Lazarus does not work.
>> Steps:
>> 1. Clear all lazarus/fpc directories (except the c:\pp\bin\i386-win32\ so
>> there's a working FPC compiler left to build again, included in the PATH
>> global environment variable)
>> 2. Check out FPC from SVN (or svn update) into c:\fpc_svn\
>> 3. cd c:\fpc_svn\ , make clean, make all, make install works OK
>> 4. Check out Lazarus from SVN (or svn update) into c:\lazarus_svn\
>> 5. cd c:\lazarus_svn\ , make clean, make all, make install works OK
>> 6. Start up Lazarus
>> 7. Tools -> Build Lazarus produces the above error
>> Therefore cannot add any packages.
>> in the Environment options
>> Lazarus Directory = c:\lazarus
>> Compiler path = c:\pp\bin\i386-win32\fpc.exe
>> FPC Source dir = c:\fpc_svn\
>> Seems to be something like
>>** http://bugs.freepascal.org/view.php?id=10433
>> Any thoughts?
> At first sight I would say that the path to the ComponentTreeView is simply
> not set.
> Without more info it's hard to tell. You would need to supply more of the
> error message, for instance why does the compiler want to recompile the
> ComponentTreeView unit ? Did it compile it before or not ?
> Michael.
> _______________________________________________
> fpc-devel maillist  -  fpc-devel at lists.freepascal.org
> http://lists.freepascal.org/mailman/listinfo/fpc-devel

More information about the fpc-devel mailing list