[fpc-devel]Building FPC 1.9.1 on BeOS

Florian Klaempfl Florian.Klaempfl at gmx.de
Sun Nov 9 00:47:27 CET 2003

BiPolar wrote:
> Hello.
> While trying to build FPC from today CVS sources on the BeOS platform 
> (using "make beoszip" from the root directory):

I guess the main problem is that the 1.0.x BeOS rtl contains a lot of 
patches which aren't merged into 1.9.x sources.

> I had to add two paths on the Makefile.fpc (./rtl/beos/) :
> ----------
> [compiler]
> includedir=$(INC) $(PROCINC) $(UNIXINC)  $(RTL)/objpas/classes $(RTL)/
> objpas/sysutils
> ----------

I tried to implement a better solution, commited. Please tell me, if it 

> After a "fpcmake" there... the "make beoszip" goes nicely until it dies 
> saying that "as" can't be found (it list my $PATH, and it _should_ find 
> "as" there).

$PATH doesn't matter, the compiler searches only in the dir where the 
compiler executable is and in the dirs specified by -FD

> Same happens with "sh" and "ar". Dropping symlinks to those binaries 
> one the compiler directory makes it work.
> After that, I tried to recompile the RTL with "make rtl smart", and now 
> it does find "ar" (because of the symlink) but fails with "Error: Can't 
> call the linker, switching to external linking". The generated ppas.sh 
> shows a line where the error is evident:

How good does a non smartlinked BeOS version work?

> "../../fpc-1.9.1/bin/beos/ar rs ./libpsystem.a ./SYSTEM.sl/system*.o"
> As the FS in BeOS is case sensitive, ar fails because all the *.o are 
> in the "./system/" directory, not in "./SYSTEM/".
> If I can be of any help on testing fixes/workarounds for this, let me 
> know.

Maybe Peter knows more :)

More information about the fpc-devel mailing list