[fpc-devel]Help - can't install nor unzip FPC

Jonas Maebe jonas at zeus.rug.ac.be
Wed Jan 24 15:03:11 CET 2001

On Wed, 24 Jan 2001, Adam Bartkowski wrote:

> >
> > What exactly do you mean by "can't install using install.exe"? And if
> > PowerArchiver doesn't work, try another unzip program. All files are in
> > the standard zip format. Since you're the first one to report problems
> > unzipping the file, I suspect your archiver is broken and not the zipfile
> > (or maybe the zipfile got corrupted while downloading).
> I have tried to start install.exe, but only the message appeared in MS-DOS
> window "This program cannot be run in DOS mode" (Strange that in DOS mode? I
> also think so.)

That's probably cause by the same thing as your corrupted zipfiles.

> The length of install.exe is 83 987 B.

That's wrong, it should be 83456 bytes. I checked in our local mirror (the
Belgian one), but it syncronizes with ftp.freepascal.org every night.

> The files I have tried to unzip were downloaded from 3 or more different
> sites (FPC main site, NL, DE, JP and Sunsite in PL) - the result was always
> the same. Archiver is OK, I have also tried to use Windows Commander internal
> unzip and Winzip 8.0. They both signal the same - archive is corrupted.
> The problem is with all ZIPs - the big one (dosw32104full.zip, length 22 930
> 411 B) as well as separeted ZIPs downloaded together with install.exe.

It seems the files are downloaded in text mode for you instead of binary
mode. Do you use an ftp client? If so, is it set to binary mode? I just
tested the big zipfile here and it checks out ok:

unzip -t dosw32104full.zip 
Archive:  dosw32104full.zip
    testing: asldw32.zip              OK
    testing: basew32.zip              OK
    testing: demo.zip                 OK
    testing: doc-htm.zip              OK
    testing: docs-pdf.zip             OK
    testing: gdbw32.zip               OK
    testing: idew32.zip               OK
    testing: install.dat              OK
    testing: installd.dat             OK
    testing: installd.exe             OK
    testing: install.exe              OK
    testing: makew32.zip              OK
    testing: readme.txt               OK
    testing: uapiexm.zip              OK
    testing: uapiw32.zip              OK
    testing: ubasw32.zip              OK
    testing: udbw32.zip               OK
    testing: ufclexm.zip              OK
    testing: ufclw32.zip              OK
    testing: ugfxw32.zip              OK
    testing: ugtkw32.zip              OK
    testing: umisw32.zip              OK
    testing: unetw32.zip              OK
    testing: upkgexm.zip              OK
    testing: utilw32.zip              OK
    testing: whatsnew.txt             OK
    testing: asldgo32.zip             OK
    testing: basego32.zip             OK
    testing: gdbgo32.zip              OK
    testing: idego32.zip              OK
    testing: makego32.zip             OK
    testing: uapigo32.zip             OK
    testing: ubasgo32.zip             OK
    testing: ufclgo32.zip             OK
    testing: umisgo32.zip             OK
    testing: unetgo32.zip             OK
    testing: utilgo32.zip             OK
    testing: cwsdpmi.exe              OK
    testing: apisrc.zip               OK
    testing: basesrc.zip              OK
    testing: compsrc.zip              OK
    testing: docsrc.zip               OK
    testing: fclsrc.zip               OK
    testing: idesrc.zip               OK
    testing: instsrc.zip              OK
    testing: pkgssrc.zip              OK
    testing: rtlsrc.zip               OK
    testing: utilsrc.zip              OK
No errors detected in compressed data of dosw32104full.zip.

Maybe you should try downloading it using a web browser instead of with an
ftp client instead (and make source you save it "As source" and not as
"text" if you use Netscape)


More information about the fpc-devel mailing list