[fpc-devel]`make install` builds 1.0.4-RELEASE?

Marco van de Voort marcov at stack.nl
Mon Jan 8 15:09:22 CET 2001

> I've succesfully built all of the sources from the FIXES_1_0_0 branch, and
> indeed the `fpc` executable in the compiler directory displays version
> 1.0.5. But if I then execute a `make install` in the top-level directory,
> 1.0.4 is installed. What is up with that?
> (Actually, I'm building on a FreeBSD box, so I'm issuing a `gmake`,
> version 3.79.1. Speaking of which, are there any known limitations to the
> FreeBSD port? I couldn't find any documented in the package.)

All questions about the FreeBSD port to me.

- Only 4.x is tested. 3.x worked before signalhandling introducing, but I
can't test that version anymore. Probably only the syscalls for
signalhandling are slightly different.
- I'm still not 100% sure about readdir.
- The IDE only works over telnet.
- alarm and time don't work yet. nanosleep does.
- Really a lot is untested in general.

If you use the FreeBSD port, do a CVS checkout, and try to build 1.0.5.

It contains header translations of console.h and mouse.h, which needs a
small patch to packrecords which is post 1.0.4

More information about the fpc-devel mailing list