[fpc-pascal] Darwin i386

Andrew Brunner andrew.t.brunner at gmail.com
Sun May 20 02:59:38 CEST 2012

I'm having a hard time with GDB and debugging threads on a OSX 10.7.4 with

The shipped gdb worked great with the exception of threads calling methods
via synchronize (so I can debug).

I'm in the process of building GDB from download and configure set gdb to
x64 darwin.  Configure detected correctly but my gdb 7.4.1 app fails to
load with some ioctl error.  I'm assuming fpc can't compile darwin x64 yet.

I tried # gdb ./configure --target=i386-apple-darwin but I think it needs
i386 gcc compiler.

I downloaded gcc from subversion and tried to configure and it too
configures make files to x64 darwin :-(

Has anyone got the latest GDB running on darwin?  Any instructions or tips
for getting gdb 7.4 working properly?
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-pascal/attachments/20120519/a4250149/attachment.html>

More information about the fpc-pascal mailing list