[fpc-pascal] FPC 2.5.1 (trunk rev 18036): Can't find unit fastcgi used by custfcgi

Marcos Douglas md at delfire.net
Fri Jul 29 22:42:35 CEST 2011

On Fri, Jul 29, 2011 at 5:18 PM, Marco van de Voort <marcov at stack.nl> wrote:
> In our previous episode, Marcos Douglas said:
>> > 1) manually delete the .ppu's in packages that have this problem ( I ran del
>> > /s *.ppu ?and *.o in packages/)
>> >
>> > 2) delete all old fpmake.exe ?(del /s fpmake.exe in packages/)
>> Ok, thanks, worked!
>> But why this?
> In some packages in 2.5.1, fpmake is being used on an experimental basis, to
> root out problems by use in practice.
>> In /branches/fixes_2_4 do not happens this error.
> These experimental changes were of course not merged back to the stable
> branch 2.4.0
> At this moment it is not decided yet if these will go in 2.6.0
>> BTW, updates for fixes_2_4 was stopped?
> 2.4.x receives some updates from time to time. Mostly fixes in packages/
> This is mostly done to have a fallback if something goes wrong with the
> start of the 2.6.x release series that is being planned for the fall.
> If that goes reasonably well, there probably will be no more 2.4.x releases.
> Merging is getting harder and harder in 2.4.x, so mostly only packages that
> are wholly merged can be merged.

OK, thanks for the explanation.

Marcos Douglas

More information about the fpc-pascal mailing list