[fpc-pascal] FPC 2.5.1 (trunk rev 18036): Can't find unit fastcgi used by custfcgi

Marcos Douglas md at delfire.net
Fri Jul 29 21:55:30 CEST 2011

On Fri, Jul 29, 2011 at 4:31 PM, Marco van de Voort <marcov at stack.nl> wrote:
> In our previous episode, Marcos Douglas said:
>> I got an error trying to compile FPC 2.5.1 (trunk at revision: 18036)
>> on WinXP-SP3.
>> Before update, I ran 'make distclean'.
>> Compiling src\base\custfcgi.pp
>> PPU Loading W:\md\dev\freepascal\compiler\2.5.1\packages\fastcgi\units\i386-win3
>> 2\fastcgi.ppu
>> PPU Invalid Version 128
>> Fatal: Can't find unit fastcgi used by custfcgi
>> Fatal: Compilation aborted
> I also had this, and this fixed it for me, and for Paul on IRC
> 1) manually delete the .ppu's in packages that have this problem ( I ran del
> /s *.ppu  and *.o in packages/)
> 2) delete all old fpmake.exe  (del /s fpmake.exe in packages/)

Ok, thanks, worked!
But why this? In /branches/fixes_2_4 do not happens this error.

BTW, updates for fixes_2_4 was stopped?

Marcos Douglas

More information about the fpc-pascal mailing list