[fpc-pascal] Installing New Components (0.9.29/2.4.1)

Technical tech at polypressuk.co.uk
Sun May 23 10:27:56 CEST 2010

On investigating this problem in more detail, it seems to be associated with 
the following circumstances :-

1) It is when trying to install in Lazarus 0.9.29 / FPC 2.4.1
2) It is specific to installing for WinCE - Win32 seems to be OK

Originally, the component was installed on 0.9.26/2.2.2 for just Win32. Then 
WinCE was added on the same installation and worked OK, with the component 
still appearing on the Component Palette. The applications using this 
component also worked OK for desktop (Win32) and smartphone (WinCE - Windows 
Mobile 6.5).

On trying the same for Lazarus 0.9.29 / FPC 2.4.1 the component installed OK 
again on the Component Palette and in the (Win32) application with Win32 
installed, but when trying to install WinCE with all the mods required by 
WinCE, the component still appeared on the Component Palette, but it does 
not work in the application running WinCE / Windows Mobile 6.5. The cells of 
the grid do not fill with data, and the grid does not appear correctly on 
the phone - there are no grid lines or cells etc.

I have also tried to install an exact copy of StringGrid on the Component 
Palette. It installs on the palette OK under Win32, but when trying install 
it again under WinCE (calling it 'NewStringGrid') and to use the new 
component (identical to StringGrid) on the WinCE application, the following 
error message appears

"The project uses target OS=Error: illegal parameter; -Twin32 and CPU=Error: 
illegal parameter; -Twin32,
The system.ppu for this target was not found by the FOC binary directories
Make sure fpc is installed correctly for this target and the fpc.cfg 
contains the right directories."

The problem now seems to be less to do with the source code of the new 
component, and more to do with the settings within Lazarus and FPC.

I have tried all obvious combinations, but without success. The same problem 
occurs with new 'virgin' installations of Lazarus / FPC aswell as 
installations added to 0.9.26/2.2.2.

Has anyone managed to install new components into Lazarus 0.9.29 / FPC 2.4.1 
and successfully run applications
using those (visual) components using WindowsCE / Windows Mobile 6.5?

Any contributions would be gratefully received.


__________ Information from ESET Smart Security, version of virus signature database 5138 (20100522) __________

The message was checked by ESET Smart Security.


More information about the fpc-pascal mailing list