[fpc-pascal] fpc 2.1.4 Intel Mac installation

Christos Chryssochoidis c.chryssochoidis at gmail.com
Tue May 22 11:20:40 CEST 2007

Jonas Maebe wrote:
> On 21 mei 2007, at 22:58, Christos Chryssochoidis wrote:
>> I downloaded the new FPC version, 2.1.4, for the Intel Mac platform 
>> to try it. When I try to install it the installer refuses to proceed, 
>> saying that "this package contains only Intel binaries which cannot 
>> be used on a PowerPC-based Macintosh. Install the PowerPC version of 
>> FPC instead." (!) Can anyone figure out what is wrong? My Mac has 
>> Intel processor.
> Sorry, my fault. Since I don't have an Intel Mac myself I was not able 
> to test the installer package and the installation requirements 
> settings I added to it. I've now however tested a similar setting for 
> the PPC package and got the same error. I've now uploaded a fixed 
> installer package (called version 2.1.4a, to distinguish it from the 
> broken one) , but you do not have to download it again as you can fix 
> the downloaded package yourself if you want to:
> a) copy the installer from the disk image to your hard disk
> b) open /Developer/Applications/Utilities/Property List Editor.app
> c) choose File->Open and navigate into the copied installer package, 
> then into the Contents folder, and open the file Info.plist
> d) scroll to the bottom, click on the disclosing triangle next to 
> IFRequirementDicts and then next to 0, and then change the following 
> settings
> * SpecArgument: change into sysa (was: gestaltSysArchitecture)
> * TestObject: change into 10 (was: gestaltIntel)
> (the problem is that I used the symbolic constant names from the 
> headers instead of their actual values)
> e) save, and then install the package
> Jonas
> _______________________________________________
> fpc-pascal maillist  -  fpc-pascal at lists.freepascal.org
> http://lists.freepascal.org/mailman/listinfo/fpc-pascal
OK, thanks very much. The fix worked fine.


More information about the fpc-pascal mailing list