[fpc-pascal] Bug in RTL for arm

Marco van de Voort marcov at stack.nl
Sun Feb 26 13:29:19 CET 2006

> Last time I checked SVN this seems solved (is it ? I modified my 
> source-file which didn't get updated, so I renamed my source-file and 
> then a new file appeared which contained the fix), but in 2.0.3 (of feb. 
> 24) it is not.
> With 2.0.3 that error I mentioned does not appear, so I'm trying with that.
> Regards,
> Koenraad Lelong.
> P.S. Is it possible that libc for arm-linux has been removed from the 
> makefiles of 2.0.3 ? First time I tried to compile MSEgui for arm-linux 
> I got an error about this, so I added it again in the makefile in 
> packages/base. I know I'm not supposed to do that but I don't know where 
> I should modify the Makefile.fpc.

Unit libc is linux/x86 only afaik, since it is a Kylix unit, which x86 only.
It might get ported to linux/amd64, but that is about it.

Use baseunix et all, which is the portable way to do Unix interfacing.

More information about the fpc-pascal mailing list