[fpc-pascal] Bug in RTL for arm

Koenraad Lelong koen1 at brouwerij.homelinux.net
Sun Feb 26 12:56:05 CET 2006

Martin Schreiber schreef:
> On Sunday 19 February 2006 19.04, Koenraad Lelong wrote:
>>Today I did an update via svn. When I compiled for arm (in the hope that
>>the bug I encountered a while ago would have disappeared) I found a bug
>>in rtl/linux/arm/sysnr.inc :
>>  syscall_nr_base = syscall_nr_base;
>>I modified this to :
>>  syscall_nr_base = $900000;
>>which is similar to fpc 2.0.2.
I seem to have forgotten to add this to my previous mail :
Last time I checked SVN this seems solved (is it ? I modified my 
source-file which didn't get updated, so I renamed my source-file and 
then a new file appeared which contained the fix), but in 2.0.3 (of feb. 
24) it is not.
With 2.0.3 that error I mentioned does not appear, so I'm trying with that.
Koenraad Lelong.
P.S. Is it possible that libc for arm-linux has been removed from the 
makefiles of 2.0.3 ? First time I tried to compile MSEgui for arm-linux 
I got an error about this, so I added it again in the makefile in 
packages/base. I know I'm not supposed to do that but I don't know where 
I should modify the Makefile.fpc.

More information about the fpc-pascal mailing list