[fpc-pascal] FPC on NetBSD (i386)

Jonas Maebe jonas.maebe at elis.ugent.be
Tue Apr 25 10:04:47 CEST 2006

On 23 apr 2006, at 19:44, Adrian Maier wrote:

>>> Yes.  the compiler is 1.0.10
>> Does "make info" also show this?
> Yes, it does. I've included the full output of 'gmake info' at the
> end of the email.
> Why do you suspect that the compiler version is not well detected?
> (the only compiler i have is 1.0.10 anyway ... )

I did because the makefile checks for FPC version 1.0.x, and if it is  
1.0.x is uses the old sysbsd.pp name instead of system.pp. But  
apparently that's solved now.

>>> and not the system unit that came with fpc 1.0.10 ? )
>> If you just run gmake in the netbsd directory, the compiler should
>> automatically use the newly compiled system unit. But there seems to
>> be something fishy with your gmake, given that it's omitting command
>> line parameters and not detecting the compiler version number
>> correctly. Which version of gmake is it? Maybe using the -d or -p
>> options of gmake may shed some light on what it's detecting and  
>> doing.
> $ gmake --version
> GNU Make 3.80
> One more thing:    when compiling rtl/inc/ctypes.pp , it was unable to
> find the unit UNIXTYPE. And i had to add to fpc.conf:
> -Fu/data/fpc/2.0.0/release_2_0_0/rtl/unix
> So,  it seems to me that it is not finding automagically all the newly
> compiled units.

That is not good. Can you post the output of a "make clean all"?  
(without this -Fu/data/fpc/2.0.0/release_2_0_0/rtl/unix added to your  
config file)

> gmake -d and -p   generate a lot of output. I'm not sure what to look
> for.

It was mainly for debugging the version number problem. Now that's  
solved it's no longer needed.


More information about the fpc-pascal mailing list