[fpc-devel] Questions regarding m68k-atari target

Thorsten Otto admin at tho-otto.de
Fri Jan 28 18:04:12 CET 2022

On Freitag, 28. Januar 2022 13:55:11 CET Thorsten Otto via fpc-devel wrote:
> i still want to try to figure out what's wrong when using gas/ld)

I get the the feeling that there must be something else going wrong:

- when i run the binary compiled by using vasm/vlink in mint, it works
- when i run the binary compiled by using gas/ld in mint, it immediately 
crashes with a bus-error.
- Running the same binaries in SingleTOS, they both give me "Internal error 
2004121202'. Then they both crash with a bus-error, too.

The error number comes from def_system_macro, when it is invoked with an empty 
name. The crash seems to happen in system.o, during initalization. The 
external name of the procedure is 'SYSTEM_$
(where does that come from?) system.o is rather large (~150k of code), 
although the source is quite small, so that seems to be some inlined code?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20220128/38cd03d3/attachment.htm>

More information about the fpc-devel mailing list