[fpc-devel] Questions regarding m68k-atari target

Thorsten Otto admin at tho-otto.de
Fri Jan 28 13:55:11 CET 2022

Now that vasm is the default, how do i switch back to gas (i still want to try 
to figure out what's wrong when using gas/ld)?

I tried -Agas, but then the compiler complains about an illegal parameter (so 
at least the help message seems to be wrong).

Then i tried -Aas, but then the compiler also complains:

Warning: (treated as error) Assembler output selected "AS" is not compatible 
with "Atari ST/STE"
Warning: (treated as error) "VASM" assembler use forced
constexp.pas(87,1) Fatal: There were 2 errors compiling module, stopping
Fatal: Compilation aborted

BTW, i think at least 3 of the commits in my PR on gitlab are now obsolete 
(but gitlab currently seems to have some problem, trying to view them does not 
display anything and causing it to search endlessly)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20220128/57d6b65e/attachment.htm>

More information about the fpc-devel mailing list