[fpc-devel] implicit generic specialization modeswitch name

Sven Barth pascaldragon at googlemail.com
Sun Mar 24 22:17:20 CET 2019

Bart <bartjunk64 at gmail.com> schrieb am So., 24. März 2019, 17:44:

> On Sun, Mar 24, 2019 at 5:18 PM Sven Barth via fpc-devel
> <fpc-devel at lists.freepascal.org> wrote:
> > I agree with Florian that a better name is needed for the modeswitch
> > ("implicitgenerics" as a different meaning in my opinion). But I don't
> > have a better idea than "implicitfunctionspecialization" either...
> implicitgenericfunctions?
> Just a little bit shorter.

No, that has the same wrong connotations. It's about specializations, but
"generic" suggests that it's about the declarations.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20190324/6140c0ba/attachment.html>

More information about the fpc-devel mailing list