[fpc-devel] Has anyone tried building FPC on an Arietta G25?

Paul Michell Paul at michellcomputing.co.uk
Fri Nov 14 12:28:31 CET 2014

For anyone else looking at FPC on an Arietta G25 I have found the cause of my problems!

It turns out that although there is a swap partition in the standard SD image, it was not mounted
in fstab.  Once enabled, the standard build processes complete without issue.

I had hoped this might also explain the other issue with subversion but that problem still persists:

root at arietta:/media/data/freepascal/2.7.1# svn up
U    compiler/globals.pas
U    compiler/ogelf.pas
U    compiler/i8086/cpuinfo.pas
U    compiler/i386/cpuinfo.pas
U    compiler/jvm/cpuinfo.pas
U    compiler/x86_64/cpuinfo.pas
U    compiler/ogbase.pas
U    compiler/powerpc64/cpuinfo.pas
U    compiler/utils/ppuutils/ppudump.pp
U    compiler/pmodules.pas
U    compiler/scanner.pas
U    compiler/arm/cpuinfo.pas
U    compiler/powerpc/cpuinfo.pas
U    compiler/alpha/cpuinfo.pas
U    compiler/nadd.pas
U    compiler/sparc/cpuinfo.pas
U    compiler/vis/cpuinfo.pas
U    compiler/ia64/cpuinfo.pas
U    compiler/options.pas
U    compiler/m68k/cpuinfo.pas
U    compiler/ninl.pas
U    compiler/aarch64/cpuinfo.pas
U    compiler/mips/cpuinfo.pas
U    compiler/mips/cpuelf.pas
U    compiler/generic/cpuinfo.pas
U    compiler/avr/cpuinfo.pas
U    compiler/ogcoff.pas
U    packages/ncurses/src/ncurses.pp
U    packages/fcl-db/examples/dbftool.lpr
U    packages/fcl-base/src/whtml.pp
U    packages/rtl-console/src/go32v2/mouse.pp
U    rtl/netbsd/pmutext.inc
U    rtl/netbsd/ptypes.inc
U    rtl/netbsd/pthread.inc
U    rtl/win/wininc/struct.inc
U    rtl/linux/i386/syscall.inc
U    rtl/unix/cthreads.pp
U    rtl/unix/tthread.inc
svn: Can't open file 'packages/cocoaint/src/webkit/.svn/tmp/entries': Read-only file system
root at arietta:/media/data/freepascal/2.7.1# 
On Wednesday 12 Nov 2014 10:19:49 Paul Michell wrote:
> I have been trying to build FPC on an Arietta G25:
> http://www.acmesystems.it/arietta[1] 
> I have downloaded the stock arm 2.6.4 from here:
> ftp://gd.tuwien.ac.at/languages/pascal/fpc/dist/2.6.4/arm-linux/fpc-2.6.4.arm-linux.tar
> And the current source snapshot from here:
> ftp://ftp.freepascal.org/pub/fpc/snapshot/trunk/source/fpc.zip
> Incidentally, I have tried running subversion to fetch the current sources, but subversion misbehaves on this platform
> and randomly crashes leaving the file system in an un-bootable state!  So to work around this I have fallen back on
> using the snapshots for now.
> From the 2.6.4 files I have extracted the compiler and system files into a seed folder and attempted to build FPC with:
> make clean all FPC=/media/data/freepascal/2.6.4-seed/ppcarm
> I have also tried cycling just the compiler with:
> make cycle FPC=/media/data/freepascal/2.6.4-seed/ppcarm
> However I start the build process, it always fails with an error 217, but not always in the same place?  I have tried extending 
> the swap partition and also adding NO_UNIT_PROCESS OPT=-dNO_THREADING in case there is a resource issue.
> The firsts iteration of the make cycle completes as I have a functional ppc1 in the compiler folder, so I assume that means I have all 
> of the right dependencies in place.  My last attempt fails at this point: 
> /bin/rm -f ppcarm
> /bin/mkdir -p arm/units/arm-linux
> /media/data/freepascal/fpc/compiler/ppc1 -Ur -Xs -O2 -n -Fuarm -Fusystems -Fu/media/data/freepascal/fpc/rtl/units/arm-linux -Fiarm -FE. -FUarm/units/arm-linux -dRELEASE -dNO_THREADING    -darm -dGDB -dBROWSERLOG  -Sew pp.pas
> make[5]: *** [ppcarm] Error 217
> make[5]: Leaving directory `/media/data/freepascal/fpc/compiler'
> make[4]: *** [next] Error 2
> make[4]: Leaving directory `/media/data/freepascal/fpc/compiler'
> make[3]: *** [ppc2] Error 2
> make[3]: Leaving directory `/media/data/freepascal/fpc/compiler'
> make[2]: *** [cycle] Error 2
> make[2]: Leaving directory `/media/data/freepascal/fpc/compiler'
> make[1]: *** [compiler_cycle] Error 2
> make[1]: Leaving directory `/media/data/freepascal/fpc'
> make: *** [build-stamp.arm-linux] Error 2
> What does error 217 mean and does anyone have any suggestions as to how I can move passed this?
> Thanks,
> Paul Michell
> --------
> [1] http://www.acmesystems.it/arietta

More information about the fpc-devel mailing list