[fpc-devel] Has anyone tried building FPC on an Arietta G25?

Paul Michell Paul at michellcomputing.co.uk
Wed Nov 12 11:19:49 CET 2014

I have been trying to build FPC on an Arietta G25:


I have downloaded the stock arm 2.6.4 from here:


And the current source snapshot from here:


Incidentally, I have tried running subversion to fetch the current sources, but subversion misbehaves on this platform
and randomly crashes leaving the file system in an un-bootable state!  So to work around this I have fallen back on
using the snapshots for now.

>From the 2.6.4 files I have extracted the compiler and system files into a seed folder and attempted to build FPC with:

make clean all FPC=/media/data/freepascal/2.6.4-seed/ppcarm

I have also tried cycling just the compiler with:

make cycle FPC=/media/data/freepascal/2.6.4-seed/ppcarm

However I start the build process, it always fails with an error 217, but not always in the same place?  I have tried extending 
the swap partition and also adding NO_UNIT_PROCESS OPT=-dNO_THREADING in case there is a resource issue.

The firsts iteration of the make cycle completes as I have a functional ppc1 in the compiler folder, so I assume that means I have all 
of the right dependencies in place.  My last attempt fails at this point: 

/bin/rm -f ppcarm
/bin/mkdir -p arm/units/arm-linux
/media/data/freepascal/fpc/compiler/ppc1 -Ur -Xs -O2 -n -Fuarm -Fusystems -Fu/media/data/freepascal/fpc/rtl/units/arm-linux -Fiarm -FE. -FUarm/units/arm-linux -dRELEASE -dNO_THREADING    -darm -dGDB -dBROWSERLOG  -Sew pp.pas
make[5]: *** [ppcarm] Error 217
make[5]: Leaving directory `/media/data/freepascal/fpc/compiler'
make[4]: *** [next] Error 2
make[4]: Leaving directory `/media/data/freepascal/fpc/compiler'
make[3]: *** [ppc2] Error 2
make[3]: Leaving directory `/media/data/freepascal/fpc/compiler'
make[2]: *** [cycle] Error 2
make[2]: Leaving directory `/media/data/freepascal/fpc/compiler'
make[1]: *** [compiler_cycle] Error 2
make[1]: Leaving directory `/media/data/freepascal/fpc'
make: *** [build-stamp.arm-linux] Error 2

What does error 217 mean and does anyone have any suggestions as to how I can move passed this?


Paul Michell

[1] http://www.acmesystems.it/arietta
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20141112/490354a8/attachment.html>

More information about the fpc-devel mailing list