[fpc-devel] bug: install directions for OS/2 2.4.2

Tomas Hajny XHajT03 at hajny.biz
Tue Feb 8 22:58:25 CET 2011

On Tue, February 8, 2011 21:37, waldo kitty wrote:
> thump! thump! is this thing turned on?

Which thing, your OS/2 box (guessing by the installed versions mentioned

> after unzipping the os2242ffull.zip to a temporary directory and reading
> the
> readme.txt file for installation instructions, it says to run the install
> executable and to make sure to update the PATH and LIBPATH entries as
> noted in
> the install program... the problem is that the install program only says
> to
> update the PATH... it took me about an hour to figure out what to update
> the
> LIBPATH with for almost perfect operation...

Yes, sorry for that. A bug regarding that has been reported and fixed
recently, but that has no impact on the release, unfortunatel (I also
updated the FAQ on our webpages accordingly, but I understand that may not
be sufficient. The problem was that the installer tries to find out which
changes to PATH or LIBPATH are really necessary, but this detection was

> i say "almost perfect" because i installed on my H: drive but i get
> notices like
> "Unknown command 'H:'"... for instance, the first time i ran make in
> H:\fpc\demo\text, i saw similar but everything seemed to compile just
> fine...

I guess that this may be related to your configuration, in particular 4OS2
which behaves slightly differently from the standard CMD.EXE. Try changing
OS2_SHELL before running make to check if it helps. As a wild guess, you
might also try running make with "ECHO=full_path_to_GNU_echo.exe".

> now when i run make in that directory, the unknown command is all i see
> and
> nothing else maybe telling me that everything is already up to date...


> OS/2 Warp 3 Connect with FP40something
> 4OS2 2.51 as OS2_SHELL
> 4DOS 7.50 as COMSPEC

4DOS isn't relevant for the OS/2 compilation, 4OS2 is (and not supported
for our makefiles; it should not matter for FPC itself or our text mode

> i also have the full EMX 0.9d environment installed... is there going to
> be a
> problem with having H:\fpc\dll in LIBPATH? do i really need that? can't i
> move a
> few of those other dlls to my existing EMX libpath location?

All of those options should work (i.e. having both directories in LIBPATH
or copying DLLs shipped with FPC somewhere else). The only thing to be
careful about (determined by order of directories in PATH, not by LIBPATH)
is the used GNU as.exe. The version shipped with the original EMX 0.9d is
too old and it does not support some newer opcodes available in newer CPUs
(this matters e.g. if you need to recompile our RTL).

> is this the proper list for these questions?
> is this the proper list to ask about installing or configuring for cross
> compiling capabilities??

fpc-pascal list (or the OS/2 specific forum on our community pages) would
be more appropriate for questions related to use of FPC. Fpc-devel list is
primarily intended for discussing implementation of new features in FPC,

Hope this helps


More information about the fpc-devel mailing list