[fpc-devel] bug: install directions for OS/2 2.4.2

waldo kitty wkitty42 at windstream.net
Tue Feb 8 21:37:16 CET 2011

thump! thump! is this thing turned on?

after unzipping the os2242ffull.zip to a temporary directory and reading the 
readme.txt file for installation instructions, it says to run the install 
executable and to make sure to update the PATH and LIBPATH entries as noted in 
the install program... the problem is that the install program only says to 
update the PATH... it took me about an hour to figure out what to update the 
LIBPATH with for almost perfect operation...

i say "almost perfect" because i installed on my H: drive but i get notices like 
"Unknown command 'H:'"... for instance, the first time i ran make in 
H:\fpc\demo\text, i saw similar but everything seemed to compile just fine... 
now when i run make in that directory, the unknown command is all i see and 
nothing else maybe telling me that everything is already up to date...

OS/2 Warp 3 Connect with FP40something
4OS2 2.51 as OS2_SHELL
4DOS 7.50 as COMSPEC

i also have the full EMX 0.9d environment installed... is there going to be a 
problem with having H:\fpc\dll in LIBPATH? do i really need that? can't i move a 
few of those other dlls to my existing EMX libpath location?

is this the proper list for these questions?
is this the proper list to ask about installing or configuring for cross 
compiling capabilities??

More information about the fpc-devel mailing list