[fpc-devel] FPC 2.6.x branched, trunk becomes 2.7.1

Marcos Douglas md at delfire.net
Wed Aug 3 21:37:04 CEST 2011

On Wed, Aug 3, 2011 at 4:27 PM, Marco van de Voort <marcov at stack.nl> wrote:
> In our previous episode, Marcos Douglas said:
>> >
>> > Every succesful "make all" generates a data2inc, and every "make install"
>> > installs it into the relevant "bin" directory.
>> So, I can put a old data2inc in /utils and to run 'make all'.
> In your PATH, or pass it with DATA2INC=(full path of data2inc binary)

This problem occurs just on Windows, ie, only Windows must have the
data2inc.exe before run 'make all'?
Sorry... but I never do this... I know, I know... 'stockmarket' right?

> I always "make install" snapshots to a prefix, e.g. ~/builded and then
> symlink relevant binaries into my path (e.g. from ~/bin to ~/builded/bin/
> and ~/builded/lib/fpc/x.y.z/ppc386)

My 'prefix' is the same directory, see the script:
set myversion=%1
set myroot=%cd%
set myFPC=%myroot%\compiler\%myversion%
set mybinutils=%myroot%\binutils
set PATH=%mybinutils%\i386-win32;%mybinutils%\x86_64-win64;%mybinutils%\arm-wince;%myFPC%\bin\i386-win32;%PATH%

cd %myFPC%
make clean all INSTALL_PREFIX=%myFPC% PP=%mybinutils%\ppc386.exe

> Typical binaries that I symlink are data2inc, fpcmake, fpcres, fpc and
> ppc386.  On machines where I work on docs also fpdoc and makeskel

I saw now:
The data2inc is in /utils directory, ie, was created today when I ran
'make all'... I did not need to copy data2inc from <trunk>/utils to

But the error still the same.

Marcos Douglas

More information about the fpc-devel mailing list