[fpc-devel] Re: Ubuntu 9.10 x64 AMD Debugging multi-threaded system impossible

Volker zipfelvo at freenet.de
Wed Feb 3 20:06:42 CET 2010

Anton Kavalenka schrieb:
> Jonas Maebe wrote:
>> On 03 Feb 2010, at 04:57, Jonathan wrote:
>>> Andrew Brunner <andrew.t.brunner at gmail.com> wrote:
>>>> Problem solved: Project options for debugging (at least under Ubuntu
>>>> x64) required extra information file...
>>>> Project Options,
>>>> Compiler Options,
>>>> Linking,
>>>> Debugging: Check Use external gdb debug symbols file (-Xg)
>>>> Fixed my GDB resulting in X-Windows desktop manager crash for Ubuntu
>>>> X64 on trace.
>>> That is good to know, I was using the guide at 
>>> http://wiki.lazarus.freepascal.org/Multithreaded_Application_Tutorial.
>>> Maybe you could update it please?
>> If you do so, please only mention it is as a tip that apparently 
>> might help if you have problems. There is no reason why using an 
>> external debug file should make any difference whatsoever, regardless 
>> of whether you are debugging a single or multi-threaded program.
>> Jonas
>> _______________________________________________
>> fpc-devel maillist  -  fpc-devel at lists.freepascal.org
>> http://lists.freepascal.org/mailman/listinfo/fpc-devel
> Dear FPC-All
> Debugging in GTK2-Linux of multithreaded GUI is a pain.
> Some notes:
> I have debugged with Eclipse C++ .so with LCL application as host, 
> Eclipse hangs as well.
> and entire X stops responding  (seems like X event loop was blocked).
> Switching to Text console and killing host application brings desktop 
> to life, but this did not help in debugging :-(
> Regards, Anton
> ------------------------------------------------------------------------
> _______________________________________________
> fpc-devel maillist  -  fpc-devel at lists.freepascal.org
> http://lists.freepascal.org/mailman/listinfo/fpc-devel
Hi Anton

I had expired similar problems with console applications. After some 
investigations i came to the conclusion that there is something wrong 
with the dynamic loading of the "pthread" library.  Removing line 18. in 
the file "rtl/unix/cthreads.pp" ( define dynpthreads} // Useless on BSD, 
since they are in libc ) solved my problem.


More information about the fpc-devel mailing list