[fpc-devel] SVN Rev. 12367 make all failed on Ubuntu 8.10/X64

Marco van de Voort marcov at stack.nl
Mon Dec 15 22:07:10 CET 2008

In our previous episode, Lukas Gradl said:
> Just reinstalled my X64 machine after changing the hardware. As Ubuntu 
> 8.10 is stable now, I decided to use it instead of 8.04.
> I first installed fpc 2.2.0 delivered via apt, then tried to compile the 
> latest svn-revision (12367) to install fpc 2.3

Trunk always requires the most recent release. And currently that is 2.2.2,
not 2.2.0. 

I know, Ubuntu is still the old version, and already in the process of
updating since september (2.2.2 was released August 11th btw) but we can't
help that either.
> I first did a "make distclean" as usual, then a "make all".
> That stopped on trying to compile pp.pas with an "EInvalidOp: Invalid 
> floating point operation"
> To check the source I did a "make distclean;make all" on a i386 Ubuntu 
> 8.04 which worked as expected.
> Anyone a little hint how to proceed?

Easiest is to download the .tar, and only extract the commandline compiler.

More information about the fpc-devel mailing list