[fpc-devel] FPC 2.0.4 is out!

Stefan Kisdaroczi kisda at hispeed.ch
Tue Aug 29 19:50:08 CEST 2006


peter green schrieb:
>> I would love to be a maintainer and build .deb files, however I do not
>> own a 64 bit CPU and can't afford one at the moment because it would
>> also mean a new motherboard and RAM too, so that crosses me out pretty
>> much. In fact, I really would love to see Free Pascal packages in the
>> Ubuntu universe repositories in the future.
> the source package is already there. The problem is that the autobuilders can't build it (because of the recursive build dep issue) and there seem to be very few people who have permission to upload manually built packages in ubuntu.
> IMO it would be a good idea to restructure the debian packaging of fpc to include starting compilers as part of the source. What do others think?

my 2 cents:
Im quite happy with the current packaging. svn update && make deb and it builds fine.
I think the main target should be that debian ships always an uptodate freepascal compiler.
The current state is very good, the freepascal repository contains the debian files and
everything is at one place, so to upload a new freepascal version to debian there are no changes needed.
Simply checkout, build and upload. (There is currently one issue, see below [1])

If you start to put binary files in the freepascal source, you can't use this for debian.
As a consequence, the debian build of freepascal and the freepascal's deb build would
need two different sets of debian packaging files and I would bet that this doesn't help
to have actual freepascal version in debian/ubuntu.

For the recursive build-dep. This is a onetime issue. The maintainer needs once to make
a binary upload and not only a source upload. After that, your build-dep is satisfied.
It has worked for debian for years, why should't it work for ubuntu?

[1] The current issue:
Until freepascal 2.0.4-rc3 the deb build worked as it should, but with the the final release is fails.
The reason was the missing libgdb binary. So I downloaded it and it worked again, but it should work without it.
There was a commit to fixes_2_0 after the release of 2.0.4, which tries to call COPYTREE libgdb in the debcopy target only if the
directory is found, something like [ -e fpcsrc/libgdb] was inserted, but it still fails, because it returns false if it doesn't
exists and "make" thinks that something has failed.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 250 bytes
Desc: OpenPGP digital signature
URL: <http://lists.freepascal.org/pipermail/fpc-devel/attachments/20060829/68ec8246/attachment.sig>

More information about the fpc-devel mailing list