[fpc-devel] is smartlink of Win32 DLLs broken again? And a old FreeBSD port problem additionaly

Pavel V. Ozerski pavel at insect.mail.iephb.ru
Wed Apr 27 09:51:53 CEST 2005

Hello all,

1) I tried now to build a dll with {$smartlink on} using 1.9.9 compiler
built at beginning of April. The created DLL did not contain export
names. An analysis of generated asm code pointed that although a
global label at beginning of .rva-containing asm-file has been
correctly created but the PASCALMAIN module did not contain a
reference to this label. At result, all EDATAs sould be eliminated at
linking stage.

2) Because I braced up, to write this letter :), I would also report a
old problem which I got using an old 1.1 FreeBSD port. I needed to
build a shared UDF library for MySQL. While loading created .so file,
I got an error message - something like "main entry point not found".
An analysis of asm code demonstated that global main function mas
named not "main" but had a name combined from a shared module name and
"_main", therefore the dynamic linker could not find main entry point.
At that time I solved this problem editing the asm code but this way
seems to be not normal.

Sincerely, Pavel

More information about the fpc-devel mailing list