[fpc-devel] bugreport: FPC 1.9.8 installer, i386-FreeBSD

Andres K. Foerster list at AKFoerster.de
Sun Apr 17 18:32:40 CEST 2005


I really had trouble installing FPC on FreeBSD.

I downloaded the big tar archive and unpacked it. Then I saw the 
file "install.sh" there. Because of the file-extension ".sh" I 
thought it was a simple shellscript for sh. So I tried to start it with 
"sh install.sh". That didn't work. So I looked into the script and saw, 
that it needs a special shell, namely bash. The extension ".sh" is very 

Well, bash wasn't installed on my system, so I had to install it. You 
should say so in the docs. Or better rewrite it to be usable with a 
standard-shell. You cannot silently expect, that everyone in the world 
is using GNU!

But then again it didn't work. I looked into the script again and 
replaced the line "VERSION=%version%" with "VERSION=1.9.8". Then at 
last it worked. Just still the IDE seems not to be installed properly, 
but I don't use it anyway.

Apropos GNU: You still use the old Cambridge address for the FSF. They 
are now in Boston. As I've heard, they plan to move again within Boston 
this summer. So look out for their actual address on their homepage:

And another comment on a new "feature". FPC doesn't let me manipulate 
the for-loop-variable anymore. That's annoying! Well Pascal was always 
said to be a bondage-and-discipline-language, but please don't force 
that any further.


More information about the fpc-devel mailing list