[fpc-devel]Re: CVS compilation problems.

Balogh, Karoly (Charlie/iNQ) charlie at scenergy.dfmk.hu
Tue Jul 15 23:20:14 CEST 2003


On 03.07.15., Marco van de Voort wrote:

>> I just cross-compiled a new PPC compiler & rtl, using yesterday's 
>> Linux/x86 snapshot compiler as the base, and using the latest CVS 
>> sources, but the problem is still there. 
> Then I think your CVS is rotten. Try to cycle with -va, and see if there
> are files marked with an asterisk, or "recompiling unit" lines.
> Try to clean linux/ manually.

I don't think it's a problem of my CVS, just look at the part of my first
message, where i quote a part of the fpcdebug.txt... the -Fi include paths
got messed up complettely.

Anyway i deleted the whole rtl directory, and checked out again, but 
nothing changed.
> --
> While the nightly ppc build failed for some vague reasons that I've
> hopefully fixed, I ran it manually, and put the generated (CVS 15-07-2003
> +/- 21:00 CET) compiler on http://www.stack.nl/~marcov/ppcppc.bz2

The compiler builds here too, but only the RTL compilation fails.
I tried with your compiler now, and the result is the same.

Charlie/iNQ      (SceneCON - http://scenecon.intro.hu)
.:%[ Cybernetic Hydraulic Android Responsible for ]%:. 
.:%[    Logical Infiltration and Exploration      ]%:.
.:%[         Member of TeamOS/2 Hungary           ]%:.
.:%[     Member of Hungarian Amiga User Group     ]%:.

More information about the fpc-devel mailing list