[fpc-pascal] Return value of StrToHostAddr and StrToHostAddr6 in sockets unit

Marco van de Voort fpc at pascalprogramming.org
Tue May 12 14:56:14 CEST 2020

Op 2020-05-12 om 12:32 schreef Michael Van Canneyt:
>> The names I use here are the libc names, which many other languages 
>> also use.
>> Now, StrToHostAddr and StrToHostAddr6 can call the appropriate 
>> function, and programs that use those functions won't notice any 
>> change. But new code will be able to use the new functions and have 
>> an unambiguous answer as to whether the address is valid or not.
>> The change is quite straightforward to make, and it won't break 
>> existing code, so I think it's worthwhile to do.
>> Any thoughts or opinions on this?
> I'm all for it, but please use the following names:
> function TryStrToHostAddr(IP: String; var ip4: in_addr): Boolean;
> function TryStrToHostAddr6(IP: String; var ip6: in6_addr): Boolean;
> Rationale for this request: All conversion calls in sysutils and 
> dateutils use this naming scheme, it's good for consistency.
> (and I hate underscores, but that's beside the point ;))
Yes to the principle and yes to the TryStrTo naming. But I would make 
the IP param CONST ;-)

More information about the fpc-pascal mailing list