[fpc-pascal] bug in make install ?

Joost van der Sluis joost at cnoc.nl
Tue Mar 19 17:35:01 CET 2019

On 3/19/19 2:06 PM, Joost van der Sluis wrote:
> On 3/19/19 11:35 AM, Mattias Gaertner via fpc-pascal wrote:
>> On Tue, 19 Mar 2019 11:17:42 +0100
>> Joost van der Sluis <joost at cnoc.nl> wrote:
>>> [...]
>>>> Probably it fails because I have old 2.6.4 fppkg configs.
>> I ran the samplecfg, which said it would create ~/.fpc.cfg, ~/.fp, ...
>> Then the error was gone.
>> I restored the files from backup. Initial dialog pops up with error.
>> But to my surprise the create config button worked.
>> So apparently samplecfg changes more files than it claims.
>> I have to find out what it does.
> This was useful information. I have the same error-message now.
> Do you also have something like this in your fppkg.cfg? (The one that 
> fails)
> Path=/home/CNOC/joost/fpc/lib/fpc/{CompilerVersion}//{CompilerVersion}/
> (Note the duplicate {CompilerVersion} ?)
> Not so easy to solve, though. I can imagine that some people do have FPC 
> installed in a directory that does not contain the compiler-version. So 
> I'll have to adapt fpcmkcfg...

On a second look it seems that this problem has been resolved already. 
Did you have an old version of fpcmkcfg, maybe?

I'll add a check for that.



More information about the fpc-pascal mailing list