[fpc-pascal] named parameter
Ryan Joseph
ryan at thealchemistguild.com
Mon May 29 06:42:21 CEST 2017
> On May 28, 2017, at 5:22 PM, Mark Morgan Lloyd <markMLl.fpc-pascal at telemetry.co.uk> wrote:
>
>> IMO though it does improve readability in long functions with lots of
>> parameters, like windows api style procedures that have 5 or more
>> parameters and you can't figure out which param is
>> which
>
You mean like this?
function Foo (theString: string; options: set of TFoo): boolean;
begin
end;
Foo(theString: 'foo', options: []);
Objective-C has this mandatory and it made for stupidly long method names that just looked terrible but it was optional Pascal makes it look nicer. The declaration syntax is already the same as the label for the calling syntax so that seems like a nice fit.
Regards,
Ryan Joseph
More information about the fpc-pascal
mailing list