[fpc-pascal] Cannot find entry point of a routine inside a windows 64 dll

Sven Barth pascaldragon at googlemail.com
Wed Dec 13 07:52:08 CET 2017

Am 13.12.2017 03:04 schrieb "Dennis" <dec12 at avidsoft.com.hk>:

I am converting my windows 32 program to 64 bit.
It compiled with lazarus without any problem.(fpc 3.0.2)

I also compile the dll that is used, into a 64 bit dll.

However, when I ran the 64 bit program, windows reported 'cannot find the
entry point "the routine name in the dll" (the dll file name)

In the routine of the dll, there is an out parameter of type WideString,

could this be the problem?

If not, what else could be the cause of the problem?

Considering the code you gave I really wonder how that ever worked... Did
you set the calling convention using the $calling directive? Otherwise you
need to add it to every function. Also you're on the eager side by using
the "name" clause for the external as you can be sure then what name is
used. Lastly are you sure that the DLL you're dealing with is a 64-bit

Maybe you should take a look at fpSpreadsheet which allows you to work with
Excel files of different versions directly and does not need a library.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-pascal/attachments/20171213/f3e52a07/attachment.html>

More information about the fpc-pascal mailing list