[fpc-pascal] fpc code for Java class and Android.

Paul Breneman Paul2006 at BrenemanLabs.com
Thu Apr 27 00:36:08 CEST 2017

On 04/20/2017 08:17 AM, Paul Breneman wrote:
> On 04/19/2017 10:49 PM, Paul Breneman wrote:
>> I'm using a Nexus 7 tablet with Android 6.0.1.  GNURoot provides a
>> chroot with Debian?  It has been *three* years since I did this before
>> and things worked then so I don't know what might have changed so ppcarm
>> doesn't even run now.
>> Android?
>> GNURoot?
>> ppcarm?
>> I'm trying the *most simple* thing, so no x11 or VNC needed.
> Actually, the FPC 2.6.0 *ppcarm* worked three years ago but not now.
> What can cause it to have an *Illegal instruction* error?
> There is a *simple* procedure near the bottom of this page:
>   http://turbocontrol.com/gnuroot.htm

I've been posting about this problem on the Lazarus forum:

A good friend of mine (who uses Debian) looked things up and found this:

Is that maybe why the *standard* 2.6.0 ppcarm is getting SIGILL when it 
shouldn't?  If so, does 2.6.4 or 3.0.0 or 3.0.2 correct this problem?

More information about the fpc-pascal mailing list