[fpc-pascal] building current trunk

wkitty42 at windstream.net wkitty42 at windstream.net
Tue Jun 21 21:37:04 CEST 2016

i posted this to the developers' list but have not had any response to it or 
another one i posted yesterday... so i'm going to post this one here in the 
hopes that someone will be able to assist me faster than the other list...


i'm trying to build trunk with my newly minted fpc 3.0.0 but i'm running into 
the following...

[ 53%] Compiled package utils-fprcp
Start compiling package utils-h2pas for target x86_64-linux.
Executing command "/home/wkitty42/development/fpc/trunk/bin/plex h2pas/scan.l 
The installer encountered the following error:
External command "/home/wkitty42/development/fpc/trunk/bin/plex h2pas/scan.l 
h2pas/scan.pas" failed with exit code 256. Console output:
TP Lex Version 4.1a [April 2000], Copyright (c) 1990-2000 Albert Graef

FATAL: cannot open file /usr/lib/fpc/lexyacc/yylex.cod

make[2]: *** [all] Error 1
make[2]: Leaving directory `/home/wkitty42/development/fpc/trunk/utils'
make[1]: *** [utils_all] Error 2
make[1]: Leaving directory `/home/wkitty42/development/fpc/trunk'
make: *** [build-stamp.x86_64-linux] Error 2
make: Leaving directory `/home/wkitty42/development/fpc/trunk'

i understand why it cannot find and open that file... it doesn't exist as there 
is no system-wide installation of fpc... there's only my user installed ones in 
my home directory...

to get here, i've just built release_2.6.4 (using the release_2.6.2 compiler) 
and release_3.0.0 (using my newly built release_2.6.4 compiler)... i have also 
compiled fixes_3_0 (with my newly built release_3.0.0 compiler)... once i worked 
out the proper order, this all worked fine with no problems... each of these is 
in their own directory...


now i'm trying to build trunk (3.1.1) and i'm having the above problem that i've 
never seen before... how can i fix it? do i need to install a ubuntu package for 
lex or something? or perhaps just creating a link for the file and point the 
link to the existing ~/development/fpc/trunk/utils/tply/yylex.cod?? probably 
also need one for yyparse.cod??

kubuntu 14.04.4 LTS

  NOTE: No off-list assistance is given without prior approval.
        *Please keep mailing list traffic on the list* unless
        private contact is specifically requested and granted.

More information about the fpc-pascal mailing list