[fpc-pascal] Methods for autoupdating fpc programs?

Bo Berglund bo.berglund at gmail.com
Sun Oct 4 10:49:43 CEST 2015

On Sun, 04 Oct 2015 00:36:09 +0200, Bo Berglund
<bo.berglund at gmail.com> wrote:

>But if I open a terminal from the menu in the VNC window it shows it
>is running as root...
>I have to check with the RPi forum on this VNC problem.

I have now found out the reason for the VNC shell running as root and
I have managed to get it half way solved...

It had to do with how tightvncserver was initialized following
installation and how the vncboot script was written for starting vnc
server on boot. The tutorial I used for freepascal and lazarus on pi
had a section on vnc access too so I used that when installing rather
than the official documentation tutorial on the pi website.

In any case I have now found it and tried to modify the installation
and vncboot script so that the VNC shell runs as pi. And this sems to
have succeeded.
But in the process ALL of the start menu programs in the VNC shell
disappeared! I now only have Run.., which does nothing, and Shutdown.
Plus the file manager and terminal on separate start icons. These two
show that the shell now runs as user pi.

But I have no idea how to get to Lazarus anymore since it disappeared
from the Menu. And I am not that used to Linux that I can fix this.
Maybe I have to scrap the SDcard and start over (another day lost).

Bo Berglund
Developer in Sweden

More information about the fpc-pascal mailing list