[fpc-pascal] access violations on new ARM hardware

Björn Schreiber news.bs at drigus.de
Mon Jan 26 10:21:43 CET 2015

Hi *.*,

   we use an ARM based SOM for a device developed by us, the software is 
developed using Lazarus. Now we are testing a new version of the SOM and 
can't get our software to work.

Old SOM:
Samsung S5PV210
one Cortex-A8 (?) core
Windows CE 6.0 R3 kernel

New SOM:
Freescale Vybrid dual core CPU
one Cortex-A5 core
one Cortex-M4 core
Windows CE 6.0 R3 / Windows Compact 7

   In order to gather some more information (even wince-stub isn't 
running on the device so we can't use GDB) we used a fresh install of 
FPC 2.6.4.

   A empty FPC program worked without any problems, even using the 
Windows function MessageBox() worked flawless. But if we included the 
unit SysUtils we got access violations right after the start - the same 
behaviour as our Lazarus application.

   By modifying the original source of SysUtils by some MessageBox() 
calls we tracked the first access violation down to the procedure 
GetFormatSettings, to be more precise to the first call of GetLocaleStr. 
If we removed the call to GetFormatSettings, the empty FPC program 
worked flawless.

FPC was used with the following command line:
fpc -Twince -Parm -FiC:\FPC\2.6.4\units\arm-wince\rtl\inc -O- test.pas

   Any ideas what goes wrong? Did we miss a compiler switch, perhaps?


More information about the fpc-pascal mailing list