[fpc-pascal] shared library on arm-linux (raspberry pi)

Fabio Luis Girardi fluisgirardi at gmail.com
Fri Jun 27 03:45:42 CEST 2014


I did more tests, with a clean raspbian image, using fpc that comes with
raspbian repositories. Now I can compile a program and the shared library,
but I can't load my shared library on my program, but my program can load
and use a shared library built in C. Maybe a FPC bug??
No, I installed FPC on Rpi using this file:


Using the FPC 2.6.4, I tried build a fresh FPC 2.7.1 on Rpi, but I found
the same error.

So, I have to go back and install FPC from Raspibian repositories...

2014-06-26 10:57 GMT-03:00 Marco van de Voort <marcov at stack.nl>:

> In our previous episode, Fabio Luis Girardi said:
> > Someone can say if this is a problem with my raspbian image or a problem
> > with my FPC installation?
> Did you use the raspbian provided (and patched!) FPC or did you build your
> own?
> Stock 2.6.4 does NOT run armhf systems, Raspbian patched theirs.

The best regards,

Fabio Luis Girardi
PascalSCADA Project
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.freepascal.org/pipermail/fpc-pascal/attachments/20140626/b0232751/attachment.html>

More information about the fpc-pascal mailing list