[fpc-pascal] Could use some help with DOS cross compile

Nikolay Nikolov nickysn at users.sourceforge.net
Sun Oct 20 20:14:30 CEST 2013

On 10/20/2013 08:12 PM, Nikolay Nikolov wrote:
> On 10/20/2013 06:31 PM, Reinier Olislagers wrote:
>> However this:
>> fpc -Pi8086 -TMSDOS d:\cop\t\test.pas
>> gives
>> Free Pascal Compiler version 2.7.1 [2013/10/20] for i8086
>> Copyright (c) 1993-2013 by Florian Klaempfl and others
>> Target OS: MS-DOS 16-bit real mode
>> Compiling d:\cop\t\test.pas
>> PPU Loading C:\development\fpctrunk\units\msdos\rtl\system.ppu
>> PPU is compiled for another i8086 memory model
>> Fatal: Can't find unit system used by test
>> What else am I missing?
> You have compiled the RTL for the medium memory model, but you're 
> trying to compile a program in the small memory model (which is the 
> default, if you don't specify -Wm). Try
> fpc -Pi8086 -TMSDOS -WmMedium d:\cop\t\test.pas
Ok, now I see you've put it in the fpc.cfg, but it could be that your 
compiler doesn't find the fpc.cfg or something similar. Try specifying 
-WmMedium on the command line when compiling and if you still get the 
same error, then probably you didn't recompile the RTL for medium model.


More information about the fpc-pascal mailing list