[fpc-pascal] Compiling arm-embedded fpc

Koenraad Lelong koen1 at de-brouwerij.be
Thu Jan 24 12:16:19 CET 2013

On 24-01-13 11:24, Jeppe Græsdal Johansen wrote:
> Looks like a memory corruption problem. I just tried to compile trunk
> with 2.6.0 as a starting compiler on win32 and had no problems(apart
> from the broken RTL).
> What starting compiler and what os/cpu are you on?


What do you mean with memory corruption ? Is the memory of my PC broken, 
or is the compiler messing with the memory and then corrupts it ?
As far as I see it's not possible to compile the RTL. That's my problem. 
The crosscompiler seems OK, when I run "ppcrossarm -i" I see the output 
I expect.
I'm trying to be as clear as possible, but sometimes I presume too much 
and the reader does not understand what I want to say :-(
What I was trying to do is pinpointing where it goes wrong. So I manualy 
tried running the last line before the compilation (how to do that : see 
the wiki) stopped with the segmentation fault. And I did this with gdb 
to get a backtrace. That's what I sent to the list.

You say you can't compile the RTL, what error do you get ?

I'm compiling this with FPC 2.6.0, on Opensuse 12.1 64 bit.

Anyway, thanks for your reply.


Koenraad Lelong.

More information about the fpc-pascal mailing list