[fpc-pascal] Copying over one .pas and modifying it - problem with debug info or... me

Reinier Olislagers reinierolislagers at gmail.com
Thu Feb 28 09:24:11 CET 2013

Cryptic subject, isn't it?

I tried to modify fpreadtiff.pas by copying only that module over to a
new directory, write a test program that uses fpreadtiff, fpimage and
other units.

AFAIK from the User's Guide, 3.1.2, the fpreadtiff.pas in my program's
directory should have been found first when searching for fpreadtiff,
while other units are found in the search path (because they're not in
my program directory).

The test program works (I've put in a writeln to show it's modified) but
debugging in Lazarus doesn't because it misses debug info.

1. Is what I am doing the right way?
2. Is there a problem with FPC generating no debug info/duplicate debug
info? I've tried both with stabs and dwarf, with standard FPC 2.6.0
without debug info as well as FPC trunk with -gw2 -godwarfsets -gl
Martin found problems with missing debug info in my log [1]

[1] Discussion on
Test program in this post:


More information about the fpc-pascal mailing list