[fpc-pascal] Compiling arm-embedded fpc

Michael Ring mail at michael-ring.org
Sun Feb 17 17:50:14 CET 2013

Hi Florian, I am not sure if this was completely clear to you, this 
problem only seems to exist on linux, my primary platform is mac, there 
this is not necessary, also not on windows.

After Koenraad expirienced this problem on 30.01.2013 I tried on my 
Fedora 18 linux system and found the same problem he described (He was 
using an opensuse system).

As you are talking about the mingw cross assembler/linker (isn't that 
mostly for windows? Might of course be that I am wrong on this one) I am 
not quite sure if you tried this on linux.

my build target was arm-none-eabi, using vanilla binutils 2.23.1 from 
ftp.gnu.org, built on fedora 18 x86_64


Am 17.02.13 16:15, schrieb Florian Klämpfl:
> Am 17.02.2013 09:28, schrieb Florian Klämpfl:
>> Am 14.02.2013 21:34, schrieb Michael Ring:
>>> I did a grep through the fpc sourcecode and found a reference in
>>> ./compiler/systems/t_linux.pas in an arm related ifdef section
>>>            add('  .note.gnu.build-id : { *(.note.gnu.build-id) }');
>>> so perhaps this is really missing in arm-embedded target.
>> This is mainly needed for the loader. But I'll try with 2.23.1, just
>> building ...
> For a newly build mingw cross assembler/linker it is not needed. What
> build target does your assembler/linker have (...-ld --version)?
> _______________________________________________
> fpc-pascal maillist  -  fpc-pascal at lists.freepascal.org
> http://lists.freepascal.org/mailman/listinfo/fpc-pascal

More information about the fpc-pascal mailing list