[fpc-pascal] Changes in 2.4.0

lists.fpc-pascal at duinheks.nl lists.fpc-pascal at duinheks.nl
Fri Apr 23 14:57:48 CEST 2010


Mar 30, Mar 30, Michael Van Canneyt wrote to lists.fpc-pascal at duinheks.nl...:

MVC > You must use -S2 or -Sd to see them. Or put  {$mode objfpc} or {$mode
MVC > delphi}
MVC > in your sources.

I tried all the hints I got. But still no luck.
In all my sources include at the beginning:
 	Compiler options
{$mode ObjFPC}
{$M 8192,0,655360}
{$IFDEF Testing}

And in my compile batch I have:
fpc -vw -Fi~/amc/src -FE../bin -Fu~/pascal/units -FU./ amc

When I try to copileis tells me:
Copyright (c) 1993-2009 by Florian Klaempfl
Target OS: Linux for i386
Compiling amc.pp
amc_directives.inc(16,3) Warning: Unsupported switch "$L"
Compiling amc_global.pp
amc_directives.inc(16,3) Warning: Unsupported switch "$L"
Writing Resource String Table file: amc_global.rst
Compiling amc_init.pp
amc_directives.inc(16,3) Warning: Unsupported switch "$L"
Compiling amc_gettext.pp
amc_directives.inc(16,3) Warning: Unsupported switch "$L"
amc_gettext.pp(89,3) Note: Local variable "s" not used
amc_gettext.pp(245,40) Error: Identifier not found "ResourceStringTableCount"
amc_gettext.pp(247,33) Error: Identifier not found "ResourceStringCount"
amc_gettext.pp(250,57) Error: Identifier not found "GetResourceStringDefaultValue"
amc_gettext.pp(251,30) Error: Identifier not found "GetResourceStringHash"
amc_gettext.pp(254,31) Error: Identifier not found "SetResourceStringValue"
amc_gettext.pp(313) Fatal: There were 5 errors compiling module, stopping
Fatal: Compilation aborted
Error: /usr/local/bin/ppc386 returned an error exitcode (normal if you did not specify a source file to be compiled)
Compilation failed!

I'm still stuck. Who can tell me what's wrong?


J.D.H. Beekhuizen
e-mail:	jdh.beekhuizen at duinheks.nl
tel:	+31(71)4015437
fax:	+31(71)4017198

More information about the fpc-pascal mailing list